无法在Linuxubuntu16.04上安装AWSSessionManager插件

我试图在我的 Linux Ubuntu 16.04 环境中安装 AWS Session Manager 插件。但是,当我将 yum 命令与 rpm 文件一起使用时,会出现以下错误:

我试图在我的 Linux Ubuntu 16.04 环境中安装 AWS Session Manager 插件。但是,当我将 yum 命令与 rpm 文件一起使用时,会出现以下错误:

sudo yum install -y session-manager-plugin.rpm
Setting up Install Process
Examining session-manager-plugin.rpm: session-manager-plugin-1.2.279.0-1.x86_64
Marking session-manager-plugin.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package session-manager-plugin.x86_64 0:1.2.279.0-1 will be installed
--> Processing Dependency: /bin/sh for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: /bin/sh for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: /bin/sh for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: /bin/sh for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.2.5)(64bit) for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.2.5)(64bit) for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.3.2)(64bit) for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: libc.so.6()(64bit) for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: libpthread.so.0()(64bit) for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: /bin/sh for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: /bin/sh for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: /bin/sh for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Processing Dependency: /bin/sh for package: session-manager-plugin-1.2.279.0-1.x86_64
--> Finished Dependency Resolution
Error: Package: session-manager-plugin-1.2.279.0-1.x86_64 (/session-manager-plugin)
       Requires: libpthread.so.0()(64bit)
Error: Package: session-manager-plugin-1.2.279.0-1.x86_64 (/session-manager-plugin)
       Requires: libc.so.6(GLIBC_2.2.5)(64bit)
Error: Package: session-manager-plugin-1.2.279.0-1.x86_64 (/session-manager-plugin)
       Requires: libc.so.6()(64bit)
Error: Package: session-manager-plugin-1.2.279.0-1.x86_64 (/session-manager-plugin)
       Requires: libpthread.so.0(GLIBC_2.3.2)(64bit)
Error: Package: session-manager-plugin-1.2.279.0-1.x86_64 (/session-manager-plugin)
       Requires: /bin/sh
Error: Package: session-manager-plugin-1.2.279.0-1.x86_64 (/session-manager-plugin)
       Requires: libpthread.so.0(GLIBC_2.2.5)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

即使我尝试安装这些丢失的包,它也不起作用。

AWS CLI 版本-& gt;aws-cli/1.20.49。Python 版本-& gt;Python 3.5.2

我将/usr/bin/yum文件的/usr/bin/python更改为/usr/bin/python2

2

Yum 不是基于 debian 的发行版的正确工具(在这种情况下,Ubuntu)

进入网站:https://docs.aws.amazon.com/systems-manager/latest/userguide/session-manager-working-with-install-plugin.html

然后向下滚动,直到“在 Ubuntu 服务器上安装会话管理器插件”部分。

本站系公益性非盈利分享网址,本文来自用户投稿,不代表码文网立场,如若转载,请注明出处

(501)
Github:每次使用后我都必须创建一个新的SSH密钥
上一篇
什么是序列化(serialization)
下一篇

相关推荐

发表评论

登录 后才能评论

评论列表(2条)