在archLinux中缺少 realvnc-vnc-viewer的依赖项(libcrypt.so.1)

当我尝试在 arch Linux 上启动 realvnc-vnc-viewer 时,缺少依赖项(libcrypt.so.1)。每次我尝试使用命令行启动 vnc-viewer 时,它都会提示这些错误:vncviewer:error while loading shared libraries:libcrypt.so.1:cannot open shared object file:No such file or directory我在 2.0 版有 libcrypt.so,但似乎 vnc-viewer 只能与版本一起使用。我已经下载了 re

当我尝试在 arch Linux 上启动 realvnc-vnc-viewer 时,缺少依赖项(libcrypt.so.1)。每次我尝试使用命令行启动 vnc-viewer 时,它都会提示这些错误:vncviewer: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory我在 2.0 版有 libcrypt.so,但似乎 vnc-viewer 只能与版本一起使用。我已经下载了 re

8

请参阅realvnc-vnc-viewer AUR page中的最新评论。

目前,有 2 种解决方案。我正在使用解决方案 2,并且可以确认它正在工作。

解决方案1

Symlinklibcrypt.so.2.0.0tolibcrypt.so.1
sudo ln -s /usr/lib/libcrypt.so.2.0.0 /usr/lib/libcrypt.so.1

解决方案2

Installlibxcrypt-compat

本站系公益性非盈利分享网址,本文来自用户投稿,不代表码文网立场,如若转载,请注明出处

(997)
如何设置 React-Table的样式
上一篇
如何创建一个简单的JavaScript计时器
下一篇

相关推荐

发表评论

登录 后才能评论

评论列表(22条)