Vue包版本不匹配:vue@2.6.14 vue-server-renderer@ 2.7.10

我试图编译我的应用程序,我得到以下错误

我试图编译我的应用程序,我得到以下错误

Vue 包版本不匹配:vue @ 2.6.14 vue-server-renderer @ 2.7.10

这是因为我使用的 Nuxt 版本(我需要使用)使用 vue-server-renderer @ 2.6.14,但我不知道是什么导致其他冲突

这里是我的依赖关系,有没有办法找出导致它的原因,或修复它?

"dependencies": {
  "@nuxtjs/axios": "5.5.4",
  "@nuxtjs/style-resources": "0.1.2",
  "@nuxtjs/svg-sprite": "0.5.2",
  "@sendgrid/mail": "6.4.0",
  "body-parser": "1.19.0",
  "chokidar": "3.5.2",
  "clipboard": "2.0.4",
  "compression": "1.7.4",
  "cors": "2.8.5",
  "express": "4.17.1",
  "feed": "4.1.0",
  "gsap": "3.1.1",
  "lazysizes": "5.3.2",
  "lodash": "4.17.21",
  "lru-cache": "5.1.1",
  "moment": "2.24.0",
  "mongoose": "5.9.10",
  "morgan": "1.10.0",
  "nuxt": "2.15.8",
  "pm2": "4.4.0",
  "sanitize-html": "2.5.1",
  "sitemap": "2.2.0",
  "stickyfilljs": "2.1.0",
  "svg4everybody": "2.1.9",
  "swiper": "6.8.4",
  "url-polyfill": "1.1.8",
  "vue-waypoint": "3.2.2"
},
"devDependencies": {
  "@babel/core": "7.18.10",
  "@babel/eslint-parser": "7.18.9",
  "eslint": "8.23.0",
  "eslint-config-standard": "17.0.0",
  "eslint-plugin-vue": "9.3.0",
  "eslint-webpack-plugin": "2.7.0",
  "normalize-scss": "7.0.1",
  "postcss-preset-env": "6.7.0",
  "sass": "1.54.7",
  "sass-loader": "10.3.1",
}

全栈跟踪

这可能会导致事情无常工作,请确保对两者使用相同的版本。

 at Object.<anonymous> (/usr/src/app/node_modules/vue-server-renderer/index.js:8:9)
 at Module._compile (node:internal/modules/cjs/loader:1120:14)
 at Module._extensions..js (node:internal/modules/cjs/loader:1174:10)
 at Module.load (node:internal/modules/cjs/loader:998:32)
 at Module._load (node:internal/modules/cjs/loader:839:12)
 at Module.require (node:internal/modules/cjs/loader:1022:19)
 at Hook._require.Module.require (/usr/src/app/node_modules/require-in-the-middle/index.js:101:39)
 at require (node:internal/modules/cjs/helpers:102:18)
 at Object.<anonymous> (/usr/src/app/node_modules/@nuxt/vue-renderer/dist/vue-renderer.js:19:27)
 at Module._compile (node:internal/modules/cjs/loader:1120:14)
1

我改变了这 3 个项目,它的工作从

  "@nuxtjs/axios": "5.5.4",
  "@nuxtjs/style-resources": "0.1.2",
  "@nuxtjs/svg-sprite": "0.5.2"

  "@nuxtjs/axios": "5.10.2",
  "@nuxtjs/style-resources": "1.0.0",
  "@nuxtjs/svg-sprite": "0.4.10"

删除模块和包锁定文件,运行 npm 安装,然后它工作

本站系公益性非盈利分享网址,本文来自用户投稿,不代表码文网立场,如若转载,请注明出处

(135)
使用CSS设置电子邮件链接/href= "mailto:" 的样式
上一篇
为访问查询创建自定义聚合函数(access aggregate function)
下一篇

相关推荐

发表评论

登录 后才能评论

评论列表(61条)